Introduction to Flash Animation

*The Flash Screen – the animator’s (that is, *your*) canvas*

**Tools Panel** – basic drawing tools.

**Stage** – where all the “hands on” work takes place.
Properties Panel – displays information specific to the selected object on the stage (or to the stage, if there is no object present).

Timeline – controls the timing, speed, and order of your animation.

Panels – toolbars that contain commands and utilities unique to the effects added to the animation.

Tools Panel

Selection – select objects, strokes, and fills.

Free Transform – resize the selected object

Line – draw lines

Text – add text
Oval – draw oval or circle

Rectangle – draw rectangle, square, or star

Paint Bucket – fill area with selected color

Eye Dropper – choose color from another object

Eraser

Stroke Color – color of lines or object border

Fill Color – color of object

**Timeline**

**Things to know before you proceed…**

*The small rectangles on the timeline layer are “frames.”*

To best describe what are frames, it is easier to begin with *keyframes:*
• **Keyframes** are the points in your animation where you want to hold images (i.e., graphics, text, and other objects) that are distinct from the rest of the animation.

• **Frames** are containers for the images that are associated with the last keyframe. The contents of a frame help you to maintain the pace of the animation, along with the “fps” setting.

*The default “frames per second” (fps) setting is 12.0.*

12 fps is fine when starting out in Flash. In time, you will find that you might need to change the speed of an animation. To change “fps” (and other settings) click on “Document” from the “Modify” menu or double-click on the “Animation Frame Speed” field:

1 – Title of the file (not the file name!!).

2 – Description of the file, if needed.

3 – Dimension of the stage.

4 – Stage background color (white is default).

5 – Frame rate (fps).

6 – Ruler units. Pixels is the default, but can be changed to inches, points, centimeters, or millimeters.

*The default background color is white.*

The background color can be changed according to your preference and the ultimate use of the Flash animation. Click on the white square to open the color palette, from which you can choose a new background color.

*Why resize the stage?*
The stage is your animation canvas. When your animation is completed, the size of the canvas will determine how and where it might fit on a Webpage. It is important to think about how your animation will be incorporated into a Website before you begin your work.

*Drawing objects...*

Flash is a drawing tools that enable you to create images for your animation. Flash lets you draw in two ways:

- **Merge mode** (default). In merge mode, if you draw one shape (e.g., a circle), then draw another shape (e.g., a square) of another color over part of the first shape, Flash erases the part of the first shape that was covered by the second shape.

- **Object mode.** In object mode, one shape does not erase another.

*Always draw or place unique objects that have distinct purposes in separate layers!!!
**Basic drawing**

You will begin your introduction to Flash drawing and animation with the moon setting and the sun just beginning to rise…

![Image of a simple drawing of a crescent moon in a blue sky over green rolling hills and the sun just beginning to rise.](image)

What is a simple drawing of a crescent moon in a blue sky over green rolling hills and the sun just beginning to rise appears as the following in the Flash timeline:
Note the following as you have a look at the timeline…

- There are layers unique to each component. Doing this will make it much easier to create animation effects with each of those components without the worry of the objects conflicting with each other.

- Each layer is ordered, top to bottom, specifically to ensure that some objects are placed behind others. For example, notice that the “sky” layer is at the bottom of the list. Since that is on the bottom, the layers listed above “sky” will appear above the sky. Similarly, the “sun” layer, which is composed of a yellow circle, is listed below the other layers.

- Some layers are not as long as others. In this example, the “moon” layer and the “guide” layer listed above it, are shorter than the other layers. By shortening the “moon” and “guide moon” layers, the “moon” object appears on in the animation for a shorter period of time.

- There are empty frames at the start of the “sun” layer. Since the “sun” is not supposed to rise until after the animation has played for two seconds, the “sun” layer cannot appear in the animation until that time (frame 24…remember, 12 frames per second!).

- Each layer, except the “guide moon” layer, has a keyframe at the end of its layer. Remember, that denotes a distinction from the rest of the layer. In the case of this animation, that distinction is the completion of the animation and, with it, distinct objects in each layer.
Begin a Project

(with an introduction to Flash animation concepts)

Create the layers

As stated previously, it is a good idea to store each component of your animation in separate frames. It is equally important to label the frames as clearly as possible. Think about what will be components of your animation and create the representative layers.

1. As you click the “Add layer” button a new layer is added above the active layer.
2. Double-click on each layer and input a new name.
3. Don’t worry if, at the start, you do not create all of the layers that you need. You can always add new layers, as needed.

Draw the objects

Drawing new objects may take some time and practice. Some things to keep in mind…

1. Draw your objects in the correct layer. Be sure to activate the layer in which you want to work.
2. Stay in “Merge Mode.” It gives you much more flexibility when creating an object.
3. Work outside of the stage. The area outside of the stage is viewable and creating or editing an object here does not impact what is viewed in the animation.

Remember: an “undo” button does not exist in Flash. If you need to undo an action (e.g., an error when drawing an object), you need to select “Undo” from the Edit menu. If you need to undo several actions, you will need to select “Undo” from Edit several times.
Drawing Concepts (and hints)

1. You can use the pointer as a reshape tool. Place the pointer on the edge of an object or on a drawn line, click and drag to reshape.

2. When an oval or rectangle is drawn with stroke (or border) enabled, the Flash treats the stroke and fill as two separate objects.

   *If you want to keep the two objects together, group them by selecting them both and choosing “Group” from the Modify menu.*

3. To draw a perfect circle or square, draw either an oval or rectangle while simultaneously depressing the “Shift” key.

4. To reshape an object use the “Free Transform” tool on the Tools Panel.
**Animate the Project**

Now that you have added layers and drawings to your project, it is time to animate. A basic function of animation in Flash is “tweening.”

**Tweening**

According to Wikipedia, tweening is short for “in-betweening.” “It is the process of generating intermediate frames between two images to give the appearance that the first image evolves smoothly into the second image. Inbetweens are the drawings between the keyframes which help to create the illusion of motion.”

Tweening saves a lot of time, since you do not need to create a unique image in every individual frame to produce the change effect. Flash offers two kinds of tweens, Shape (morphing) and Motion.

**Shape tweens** enables you to create an effect that makes an object slowly change its appearance over time. Such changes include color, shape, position (only in a straight line, though!!). Create a shape tween:

1. Open a new Flash document.

2. In frame one, choose the oval tool and draw a red circle (remember the Shift key for perfect circles!!!) anywhere on the stage.

3. Place your cursor over frame 15, right-click and choose “Insert Blank Keyframe” from the pop-up menu.
You will notice that the blank keyframe in frame 15 contains no objects.

*Remember, each keyframe is the point in your animation where you want to hold images (i.e., graphics, text, and other objects) that are distinct from the rest of the animation.*

4. Draw another circle in the blank keyframe (it can be any color or size you like).

5. Now, click on any frame between frames 1 and 15 and choose “Shape” from the Tween drop-down menu in the properties bar.
6. To test your animation, select “Test Movie” from the Control menu.

*There is one shape tween in the “crescent moon over rolling hills” animation. Do you know what it is??*
More on Tweens

Earlier, it was mentioned that there are two kinds of tweens. We have reviewed shape tweens. Before we move on to motion tweens, let’s review when you would use a shape tween as opposed to a motion tween.

You want to use a shape tween when you want to work with an editable object or want to show a shape change. On the other hand, you must use a motion tween when you want to show motion that does not show a straight line (spinning, swooping, etc.). Uneditable objects can be expanded or shrunk by using a motion tween.

“Uneditable objects” and the Library

Before moving on to motion tweens, a word or two about uneditable objects (EO). There are basically two sources for EOs: those that you create in Flash and those that you import to Flash. There are three kinds of EOs (symbols, in Flash) that you can create in Flash: movie clips, buttons, and graphics. For the purpose of this seminar, only graphics will be discussed.

Suppose you want to make the red ball that was created above “loop” on the canvas. The red ball must first be converted to a Flash graphic:

1. Click on the red ball.
2. Select “Convert to Symbol” from the Modify menu.
3. In the “Convert to Symbol” dialog box, select “Graphic” under Type and type a unique name in the “Name” field (e.g., RedBall).
4. You will notice that the “RedBall” graphic has been added to the Flash file Library.

The Flash Library is typically displayed in Panels. If the Library (or any other panel) does not appear, click on the Window menu and choose the panel you wish to display.

The Library

Flash has two libraries, the “Common Libraries” and the “Library.” The Common Libraries are available in every Flash file and contain pre-constructed objects that can be added to any Flash file. The Library is unique to each Flash file. In the example above, the RedBall graphic is automatically stored in the file’s Library and cannot be accessed from other files.

You can import existing files that have been created in other programs to the Library of any or all of your Flash files. To use a Library file, simply click on it and drag to the stage.
Motion Tweens

As stated above, only uneditable objects can be used in motion tweens. One of the most popular uses of a motion tween is to create the effect of nonlinear motion. For example, let’s create a looping effect with RedBall (and introduce a new concept along the way):

1. Change the name of the layer in which you have been working to “Ball.”
2. Move the RedBall graphic to a spot on the stage that you want to be the starting point.
3. Click on the “Add Motion Guide” layer button.
4. A new layer is added above the Ball layer. You will notice that the Ball layer is indented slightly beneath the guide layer, signifying that the Ball layer is subordinate to the new guide layer.
New Concept: To create a nonlinear effect, you must use a guide layer to create the effect. The guide layer is where you will create the nonlinear path on which the object will move.

Create the Guide Path

1. In the guide layer:
   a. Right-click on the frame that you want to end the object’s motion and insert a blank keyframe, in this case use frame 30.
   b. Click on frame 1 of the guide layer and draw an empty oval, that is, with no fill.
   c. Use the eraser tool to erase a very small portion of the top of the oval.
   d. Still in frame 1, right-click on the edited oval and select “Copy” from the pop-up menu.
e. Click on frame 30 of the guide layer and select “Paste in Place” from the Edit menu.

2. In the Ball layer:
   a. Insert a blank keyframe in frame 30.
   b. Right-click on the RedBall graphic in frame 1 and select “Copy” from the pop-up menu.
   c. Click on frame 30 and select “Paste in Place” from the Edit menu.

3. Create the motion:
   a. Activate the RedBall graphic in frame 1 of the Ball layer and place the small circle with the cross-hairs at the “starting” point of the loop. In this case, use one of the ends of the oval that was created when you erased a portion.
   b. In frame 30, place the RedBall graphic on the other end of the oval.
   c. Select any frame on the Ball layer between 1 and 29, then choose “Motion” from the Tween drop-down menu.
   d. Test the movie by selecting “Test Movie” from the Control menu (see the figure on the next page).

There is one motion tween in the “crescent moon over rolling hills” animation. Do you know what it is??
Masks

Masks can create unique effects in a Flash animation. Masks can be used as a roaming spotlight on the canvas or as an expanding porthole to an object. When you begin to use mask layers to create mask effects, it is easy to become confused about what is a Flash mask. Essentially, when you create a mask layer the entire layer is the mask; the object that you create on the mask layer is actually a “hole” in the mask. This is best demonstrated with an example:

1. Open a new Flash file.
2. Rename the initial layer “Object.”
3. Select “Import → Import to Library” from the File menu and import a graphic file to the Flash file Library.
4. Drag the graphic file onto the stage and resize it, if needed.
   
   *Note: the object upon which will be created the effect must be a graphic file (e.g., .jpg, .gif, etc.) imported from outside of Flash. The graphic file cannot be created in Flash.*

5. Insert a keyframe in frame 40.
6. Insert a new layer above the “Object” layer.
7. Right-click on the new layer and select “Mask” on the pop-up menu.
8. When the mask layer is added, both the mask and Object layers are locked. Unlock the layers by clicking on the “lock” icons on each layer.
9. Rename the mask layer “Mask.”

Now that the mask has been created, we need to create the “hole” in the mask that will create the effect we want.

1. Click on frame 1 on the Mask layer and draw an oval (try a perfect circle) to “cover” the Object layer graphic.
   a. At this point, test the movie (“Test Movie” from the Control menu) to see what the circle that you drew on the Mask layer has produced. You should see the Object layer graphic.

2. Use the scale tool to resize the circle as small as possible and place it in the middle of the Object graphic.
   a. Test the movie again…you should see something like this:
b. By resizing the circle on the Mask layer you have made the “hole” in the mask smaller!

3. Now, we can use a shape tween to “expand” the spotlight to reveal the entire Object graphic!

   a. Retain the small circle in frame 1 of the Mask layer.

   b. Insert a keyframe in layer 40 of the Mask layer.

      i. Since the small circle already existed in frame 40 of the Mask layer, you do not need to redraw it or copy/paste it from frame 1.

   c. Use the scale tool to resize the circle in frame 40 to cover the entire Object graphic.

   d. Click on a frame between 1 and 40 in the Mask layer and select “Shape” from the Tween drop-down.

   e. Test your new movie!
**ActionScript**

ActionScript enables you to add interactivity to your animation by linking a programmable action with an object in your Flash file. ActionScript can create very complex effects in Flash and requires a great deal of time and experience to master. As an introduction to ActionScript, you will add a very simple function to your Flash animation: `stop`.

Notice that when you test any animation it never ends – it constantly performs the animation over and over. That is because there is no command built in to the animation to tell it to stop! To add the stop action:

1. Open the “Actions” panel in the Window menu.
2. Click on frame 40 on the Mask layer.
3. In the Action panel, type “`stop ();`” (including the semi-colon!).
4. Test your movie!