What is Microsoft Excel?
Microsoft (MS) Excel is a spreadsheet program with sophisticated computation, charting, and database functions that enable the user to quickly and easily perform both simple and complex calculations.

You can confirm changes in the figures without the need to calculate them yourself. Excel also provides many formatting options that add quality to your presentation representing both the figures and the images you want to present.

Spreadsheet Design
Spreadsheet design skills are important for Excel users. Unlike many other computer programs, spreadsheets require thought and planning to make them efficient and effective. To develop useful spreadsheets, consider the following elements:

- What are the desired outputs?
- What are the needed inputs?
- How is the data positioned?
- What mathematical expressions must be used?
- Who will be using the spreadsheet?

Starting Excel
- Select Programs from the Start menu and toggle to Microsoft Office. Choose Microsoft Excel 2007.
  or
- Double-click on the Excel icon located on the Windows Desktop, if present.
  or
- Open any existing Excel file. Note: Files saved in an earlier version of Excel can be opened in Excel 2007 using this method.
Elements of the Excel Screen

- Quick Access Toolbar
- Office Button
- Ribbon
- Name Box
- Formula Bar
- Column Letter
- Active Cell
- Row Number
- Sheet Tab
- Zoom controls
Quick Access Toolbar

The Quick Access Toolbar provides immediate access to the functions stored on the toolbar.

- Save, Undo, and Redo are default functions.
- Can be customized from a pre-configured list of functions available from the drop-down button adjacent to (the right of) the Quick Access toolbar.
- Can be additionally customized via application options:
  - Click on the Office Button
  - Click on the application Options button
  - Click on Customize
  - Select the function(s) that you want to add to the Quick Access toolbar from the left panel.
  - Click “Add”
  - Each function will appear in the right panel, which represents the functions on the Quick Access toolbar.
Office Menu (via the Office Button)

Click on the Office Button to open the Office menu. Many of the functions that were available in the File menu in previous versions of MS Excel can be found in the Office menu. Other interesting and important aspects of the Office Button are:

- Functions with additional options (e.g., “Save As,” “Print,” etc.) are denoted by an arrow and can be expanded by toggling to the icon and maintaining the cursor over the function.

- The “Recent Documents” field displays all files recently opened using the application. The upper limit is 50.

- The “Excel Options” button enables you to access the environment where Excel application changes, such as “Display,” “Save,” “Edit” options, can be made.

- The location of the Office Button cannot be changed. However, to change the location of the Quick Access toolbar and the display size of the Ribbon, right-click on the Office Button to invoke the pop-up menu.
**Ribbon**

The Ribbon is a horizontal bar that contains all application functions and commands.

- The Ribbon is divided by tab headings that describe the commands contained within.
- The location of the Ribbon cannot be changed.
- The Ribbon can be minimized:
  - Right-click once on a blank portion of the Ribbon tab bar and select “Minimize the Ribbon” from the pop-up menu.
- The dialog box related to each set of commands can be launched by clicking on the arrow in the bottom-right corner of that section.
  - NOTE: not all sets of commands contain a dialog box arrow.
- An entire set of Ribbon commands can be added to the Quick Access toolbar:
  - Right-click once on a blank portion of the section’s title bar and select “Add to Quick Access toolbar” from the pop-up menu.

**Other Elements**

**Name Box**
The Name Box displays the cell reference or the name of the active cell or set of cells.

**Formula Bar**
The Formula Bar displays the contents of the active cell. Data entering or editing can be performed directly in the Formula Bar.

**Column Letter**
Each vertical column in a worksheet is identified by a column letter, located in the column header.

**Row Number**
Each horizontal row in a worksheet is identified by a row number, located in the row header.

**Sheet Tab**
Click on a sheet tab to navigate between the sheets contained in the workbook.

**Zoom Controls**
The cell grid can be magnified or shrunk using the Zoom controls.
Workbooks and Worksheets

The workbook is a collection of sheets that enable you to better organize your work. A workbook can contain worksheets, charts, macros, or other types of sheets. A workbook can contain as many sheets as the computer memory will support. The Sheet Tabs, located in the bottom-left corner of the screen, displays the list of sheets in the current workbook.

The Worksheet

The worksheet is the area in which you perform spreadsheet work. It is divided into a grid of columns and rows. Each worksheet contains up to 16,384 columns and 1,048,576 rows. Each intersection of a column and row forms a cell. Each cell is identified by its address, or cell reference: the column letter and row number (e.g., A4, B32, CC2777).

Selecting Cells

When you want to make a change to a cell, or set of cells, you must first select the cell(s). To select one cell, position the cursor inside the cell area and click once with the left mouse button. To select a group of cells, click on one cell, hold down the left mouse button and drag across the cells you want to include in the selection. If you have selected too many, or incorrect, cells, click once outside the area selected to clear the selection and try again.

If you wish to select a large area of adjacent cells, hold the Shift key and drag the cursor across the area you wish to select. To select non-adjacent ranges of cells use the Ctrl key in the same manner. To select entire rows or columns, place the cursor on the button that identifies the row or column and click once.
**Entering Data**

Data, including text, numbers, or formulas, is input to a cell by clicking once to select (and activate) the cell and typing. The data will appear in two locations, in the cell itself and in the **Formula Bar**. The data is stored by the cell when you hit the Return key, the Enter key, the Tab key, or any of the direction (arrow) keys. Data is also stored when the green check box adjacent to the Formula Bar is clicked.

**Editing Cells**

To edit the contents of a cell you must first click on the cell to activate it. Its contents will appear in the **Formula Bar**. Contents can be edited from within the **Formula Bar**.

**Delete Cell Content**

To clear the contents of a cell click on it and choose the **Clear** command from the **Editing** box, found in the **Home** tab. **Clear** prompts you to choose what details to delete: formats, contents, or everything.

*Note:* the Delete key clears the cell content, not formatting. **Do not** use the spacebar to clear cells; it adds a space to the cell rather than deleting the contents.

**Copy or Cut Cells**

Excel enables you to copy or cut cells from one location to another. Select the cell, or range of cells, to copy or cut, then choose either **Copy** or **Cut** from **Clipboard** box found in the **Home** tab. The cells are activated and their contents displayed until the **Paste** function is completed.

**Rows and Columns**

**Rows**

There are two options to insert a row:

1. Place the cursor in the row heading and click once on the right mouse button. Select **Insert** from the pop-up menu. A new row will be inserted above the selected row.
2. Left click once on the row heading and select **Insert Sheet Rows**, found under **Insert**, in the **Cells** box under the **Home** tab (Home→Cells→Insert→Insert Sheet Rows). A new row will be inserted above the selected row.

Two methods to delete a row:

1. Place the cursor in the row heading and click once on the right mouse button. Select **Delete** from the pop-up menu.
2. Left click once on the row heading and select **Delete Sheet Rows**, found under **Delete**, in the **Cells** box under the **Insert** tab. (Home→Cells→Insert→Delete Sheet Rows)
**Columns**

There are two options to insert a column:

1. Place the cursor in the column heading and click once on the right mouse button. Select **Insert** from the pop-up menu. A new column will be inserted to the left of the current column.
2. Left click once on the row heading and select **Insert Sheet Columns**, found under **Insert**, in the **Cells** box under the **Home** tab (Home→Cells→Insert→Insert Sheet Columns). A new column will be inserted to the left of the current column.

Two methods to delete a column:

1. Place the cursor in the column heading and click once on the right mouse button. Select **Delete** from the pop-up menu.
   a. Left click once on the row heading and select **Delete Sheet Columns**, found under **Delete**, in the **Cells** box under the **Insert** tab. (Home→Cells→Insert→Delete Sheet Columns)

**Note**: To insert or delete two or more columns you must select the number of columns by highlighting that number of columns (click and drag over the column headings).

**Workbooks**

Excel includes sheets within a single file (or workbook). Sheets can be used as individual entities, with formatting and formulas exclusive to each sheet, or as components within a series of sheets. Three sheets are available by default when a new workbook is opened.

**Workbook Navigation**

Use the sheet tabs, located on the bottom left of the workbook, to move between individual sheets. The tabs display the name of each sheet in the workbook. The active sheet is displayed in bold on a white background. The scroll buttons, to the left of the sheet tabs, can be used to navigate quickly among the sheets in the workbook.
Sheet Names

Sheets are given the default names of ‘Sheet1’, ‘Sheet2’, etc.. To change the name of a sheet, double click on the tab and type in a new name. Sheet names must adhere to the following rules:

- No more than 31 characters in length (including spaces).
- Each sheet name must be unique within the workbook.
- Cannot include the following characters: \,/,*,?,: 

Inserting and Deleting Sheets
Click on the “new sheet” button or click on the sheet tab to the right of the desired insertion point to insert a new sheet into a workbook. Then click on the tab with the right mouse button to launch the pop-up menu. Choose **Insert** from the menu and select the type of sheet you want to insert. To delete a sheet from a workbook right click and select **Delete** from the shortcut menu.

Moving and Copying Sheets
Move a sheet from one location to another within a workbook by dragging and dropping the sheet’s tab at a new location. You can make a copy of a sheet in the current workbook by selecting the sheet to be copied, holding down the **Ctrl** key and dragging the sheet to the new location.
A sheet can be moved to another workbook by dragging the sheet tab to that workbook. To copy a sheet from one workbook to another, hold down the Ctrl key before you select the sheet. You must first have the other workbook open and tiled in the same windows. The **Move or Copy Sheet** selection under the *Edit* menu enables you to do the same.

**Editing a Group of Sheets**

Excel’s workbook approach makes it easy to set up or edit files sharing common information or a common format by using group-editing techniques. To edit multiple sheets you must first group the sheets together. There are three methods to grouping worksheets:

- To group adjacent worksheets select the first sheet and, while holding down the **Shift** key, click on the last sheet.
- To group non-adjacent worksheets select the first sheet and, while holding down the **Ctrl** key, click the tab of each additional sheet.
- To select all worksheets in a workbook activate the tab shortcut menu and choose **Select All Sheets**.

Once the sheets are grouped you will note that nearly everything you do in the first sheet is repeated in the others. This is convenient for applying formats, entering text or formulas, changing column widths, etc.. When you are finished making your change activate the shortcut menu and choose **Ungroup Sheets**.
Formatting Cells, Columns and Rows
You can easily change the width of a column or the height of a row by positioning the cursor on the line between a particular column or row and the adjacent one. When you have positioned the cursor it will change to a thick line with arrows pointing in opposite direction (not shown). Once the new cursor appears click and drag to make the required changes.

Formatting – the 6 Tab Box

Formatting changes can be made to cells, a range of cells, individual characters within a cell, columns or rows. To perform format changes select the items that will be formatted and select Cells from the Format menu. Or, Format Cells can be selected from the pop-up menu. The Format Cells dialog box will be activated, enabling you to select any of the following formatting categories: Number, Alignment, Font, Border, Fill, or Protection.

Number
The Number tab helps you determine how numeric information is displayed. You can use one of the built-in number formats or create custom formats by selecting Custom from the Category list. When Custom is selected the built-in custom formats are displayed in the Type box.
Notes:
- All cells in a new worksheet are formatted with the **General** format.
- To add a custom format edit the one shown in the **Format** box or type a new one in the **Type** box. The custom format is added to the **Custom** category.
- Use the **Delete** button to delete custom formats. **Built-in number formats cannot be deleted.**

Alignment
The Alignment tab box provides options for aligning the contents of cells.

The **Horizontal** option adjusts the left/right orientation.
- The **General** option, which is the default setting, aligns text to the left, numbers to the right.
- **Left (Indent)** aligns all text and numbers to the left.
- **Center** aligns all text to the center of the cell.
- **Right (Indent)** aligns all text and numbers to the right.
- **Fill** repeats the contents of the selected cell to fill the cell. Blank spaces are incorporated, as well. *The contents will fill the cell regardless of the column width.*
- **Justify** aligns text within a cell to the right and the left.
- **Center Across Selection** centers a cell entry across selected cells.

The **Vertical** option aligns cell entries with the top, center or bottom of a cell.

The **Orientation** enables you to rotate selected cell entries.

Font
Font options include: font, font style (bold, italics, etc.), font size, underlining, text colors and effects such as strikethrough, superscript and subscript. **Any time you wish to change text back to the default font simply check Normal Font in this dialog box.**

Border, Fill, and Protection
The Border and Fill tab dialog boxes help you emphasize portions of your spreadsheet by applying borders or fill colors and patterns. The Protections dialog box enables you to secure cells either by locking them so that they cannot be changed or by hiding the formulas in cells so that other cannot see them.
**Formulas and Functions**

**Calculations and Order of Operations**
To create mathematical expressions rules must be observed to calculate correct answers. The following is the order used by Excel to calculate mathematical expressions (from highest to lowest):

- Expressions contained within parentheses
- Percent
- Exponential notation
- Multiplication and Division
- Addition and Subtraction

**Note**: this is just a sample of the most common mathematical expressions that can be used in Excel. Additional expressions are available for use.

**Entering Formulas**
To enter a formula in a cell click on the cell, type the equal to (=) character and enter the formula. If you forget to enter the = character Excel will treat the expression like text and it will not be calculated.

Simple formulas can be input to a cell by typing in the mathematical expression:

Notice that the appearance of the **Name Box** has changed to indicate that the formula being input to cell A1 is a SUM. Also, the formula appears in the **Formula Bar** as the formula is being typed.

To avoid any confusion as a result of data updates, Excel enables you to create formulas using cell references:
Any changes made to the data contained in the cells referenced in the formula will be automatically reflected in the formula output.

**Entering Functions**
Functions have three parts. The first is the equals to character (=), which indicates to Excel that a formula or function will follow. The second is the function name, such as SUM or AVERAGE (for determining the average of a series of numbers). The third is the argument on which the particular function operates. The argument contains cell references to let the function know which data to calculate. The argument must be enclosed by parentheses.

**The Function Wizard**
To use the Function Wizard to create a formula, select the cell in which the formula is to be created. Click on the Insert Function button on the Formula Bar.

The Function Wizard is a two step process:

1. Select the function you wish to use from the Select a Function box.
2. You are prompted to select the fields to be included in the argument.

You can type in the cell references for the argument or simply select the rows or columns directly from the worksheet.

**Note:** the steps noted above are also applicable when you type the equal to character (=) in a cell. In this scenario, the Name Box displays functions. Select the function you wish to use and select the fields.

**AutoSum**
AutoSum enables you to create a formula. Perform the following steps to invoke AutoSum:

- Select the desired cell to place the formula.
- Click on the AutoSum button located on the Home tab or the Formulas tab.

Excel will then activate the selected cells (a rotating dashed line, similar to a marquee) will appear surrounding the cells. You can select any number of cells to add to the AutoSum formula.
• Press the Enter key and the formula will be created.

**Note:** many functions are available using the AutoSum button. Select the drop down arrow to display the available functions.
AutoFill

The AutoFill function can be used to input formulas to cells that are used for the same function. For example, in the example below an AutoSum formula has been created in cell A5. The AutoSum formula in A5 can be copied to B5 to replicate the formula and reflect the change to column B to include cells B1 through B4.

Use the AutoFill button, found at the bottom right of the active cell, to click and drag to the cells to which you would like to copy the formula.